Load Balancing Mikrotik

Setting Load Balancing 2 Provider Internet

Setting atau konfigurasi load balancing 2 provider internet sederhana pada mikrotik sangat mudah dilakukan. Konfigurasi semacam ini diperuntukkan kepada teman-teman yang butuh up time internet baik untuk perkantoran maupun warnet atau game online. Dibawah ini akan saya tuliskan urutan bagaimana cara membuat router mikrotik menjadi load blancer penggunaan bandwidth supaya salah satu link bukan sekedar standby use saja. Tapi bisa dimanfaatkan kedua-duanya untuk masing-masing client dan difungsikan auto fail-over jika salah satu link mengalami putus atau gangguan.

Konfigurasi setting Load Balancing mikrotik router

Dari contoh agambar di atas ada 2 buah provider internet anggap saja provider A dan B dengan penamaan di mikrotik nanti menjadi (provider-a) dan (provider-b). Mari kita coba membuat suatu sampling study kasus dengan data-data sebagai berikut :

  1. IP Modem A (Provicer A) 192.168.1.254.
  2. IP Modem B (Provider B) 192.168.2.254.
  3. IP Router (Mikrotik) LAN 192.168.0.1 (Ethernet Port 3).
  4. IP Client masing-masing nanti DHCP dari mikrotik.

Dengan data seperti diatas maka langkah awal adalah kita masuk ke mikrotik menggunakan winbox via laptop client 1. Sementara biarkan DHCP mendapatakan IP Address dari segment auto configuration.

  • Masuk ke menu konfigurasi mikrotik menggunakan winbox, kemudian masuk ke telnet pada winbox.
  • Set nama ethernet default menjadi seperti ini dengan script sebagai berikut (bisa di copast) :

/interface ethernet
set numbers=0 name=eth1-provider-a
set numbers=1 name=eth2-provider-b
set numbers=2 name=eth3-local
set numbers=3 name=eth4-backup
set numbers=4 name=eth5-backup

  • Set IP Address masing-masing port dan bridge pada mikrotik

/interface bridge
add name=br-local
/interface bridge port
add bridge=br-local interface=eth3-local
add bridge=br-local interface=eth4-local
add bridge=br-local interface=eth5-local

/ip address
add address=192.168.1.1/24 interface=eth1-provider-a
add address=192.168.2.1/24 interface=eth2-provider-b
add address=192.168.0.1/24 interface=br-local

  • Kemudian menambahkan route script untuk fail-over sebagai berikut

/ip route
add check-gateway=ping comment=news distance=1 gateway=8.8.8.8
add check-gateway=ping comment=news distance=1 gateway=8.8.4.4 routing-mark=auto-fail
add check-gateway=ping comment=news distance=2 gateway=8.8.4.4
add check-gateway=ping comment=news distance=2 gateway=8.8.8.8 routing-mark=auto-fail
add distance=1 dst-address=8.8.4.4/32 gateway=192.168.1.254 scope=10
add distance=1 dst-address=8.8.8.8/32 gateway=192.168.2.254 scope=10

  • Kemudian konfigurasi dhcp server untuk masing-masing client dan dilanjut pada artikel berikutnya ya, masih banyak kerjaan nih.. 🙂